Installing Bioperl on UCLA cluster

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing Bioperl on UCLA cluster

Allison Fritts-Penniman
Hi,

I am trying to use the program VelvetOptimiser, which requires BioPerl. I
just followed your instructions for installing in my directory on the UCLA
computer cluster, but at the ./Build test I get this final output:

Files=337, Tests=0, 10 wallclock secs ( 1.74 usr  1.18 sys +  4.84 cusr
3.48 csys = 11.24 CPU)

Result: FAIL
Failed 336/337 test programs. 0/0 subtests failed.

I'm thinking this may be related to the fact that when I first ran Build.PL
I got some errors:

 - ERROR: Test::Most is not installed
 - ERROR: IO::String is not installed
 - ERROR: Data::Stag is not installed

What can I do to fix this?

Thanks,
Allison
_______________________________________________
Bioperl-l mailing list
[hidden email]
http://lists.open-bio.org/mailman/listinfo/bioperl-l
Reply | Threaded
Open this post in threaded view
|

Re: Installing Bioperl on UCLA cluster

Fields, Christopher J
You need to install those missing modules, that’s likely the reason for the test failures.

If you are installing to a local (user) directory I highly suggest using local::lib in combination with cpanminus (cpanm).  It will save you a lot of pain.

http://stackoverflow.com/questions/2980297/how-can-i-use-cpan-as-a-non-root-user

chris

On May 21, 2014, at 2:06 PM, Allison Fritts-Penniman <[hidden email]> wrote:

> Hi,
>
> I am trying to use the program VelvetOptimiser, which requires BioPerl. I
> just followed your instructions for installing in my directory on the UCLA
> computer cluster, but at the ./Build test I get this final output:
>
> Files=337, Tests=0, 10 wallclock secs ( 1.74 usr  1.18 sys +  4.84 cusr
> 3.48 csys = 11.24 CPU)
>
> Result: FAIL
> Failed 336/337 test programs. 0/0 subtests failed.
>
> I'm thinking this may be related to the fact that when I first ran Build.PL
> I got some errors:
>
> - ERROR: Test::Most is not installed
> - ERROR: IO::String is not installed
> - ERROR: Data::Stag is not installed
>
> What can I do to fix this?
>
> Thanks,
> Allison
> _______________________________________________
> Bioperl-l mailing list
> [hidden email]
> http://lists.open-bio.org/mailman/listinfo/bioperl-l


_______________________________________________
Bioperl-l mailing list
[hidden email]
http://lists.open-bio.org/mailman/listinfo/bioperl-l