Re: Latest BioPerl (version 1.7.1) is lacking wrapper support

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Latest BioPerl (version 1.7.1) is lacking wrapper support

Carnë Draug-2
On 16 December 2016 at 10:02, Andreas Tille <[hidden email]> wrote:

> Hi,
>
> when trying to run Bioperl-run unit tests while BioPerl 1.7.1 is
> installed (on a Debian system with the current Debian package in
> unstable) I get lots of errors of type
>
>    Can't locate Bio/Tools/Run/WrapperBase.pm in @INC (you may need to install the Bio::Tools::Run::WrapperBase module)
>
> When checking BioPerl 1.6.x hat a file Bio/Tools/Run/WrapperBase.pm
> which was removed in BioPerl 1.7.x and thus lots of tests are failing.
>
> Kind regards
>
>      Andreas.

That module (Bio::Tools::Run::WrapperBase) is now part of bioperl-run [1].
Unfortunately, it seems that there has been no new release of bioperl-run
since that change.

I am not sure what's the plan for bioperl to make a new release of
bioperl-run (adding bioperl mailing list to CC) but can Debian patch
bioperl-run to include those files like upstream has done for the
next release?

Carnë

[1] https://github.com/bioperl/bioperl-run/commit/acd57a7d14112c5fd2cd979005b072efdaf57679

_______________________________________________
Bioperl-l mailing list
[hidden email]
http://mailman.open-bio.org/mailman/listinfo/bioperl-l
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Latest BioPerl (version 1.7.1) is lacking wrapper support

Fields, Christopher J
On 12/16/16, 5:11 AM, "Bioperl-l on behalf of Carnë Draug" <bioperl-l-bounces+cjfields=[hidden email] on behalf of [hidden email]> wrote:



>On 16 December 2016 at 10:02, Andreas Tille <[hidden email]> wrote:
>> Hi,
>>
>> when trying to run Bioperl-run unit tests while BioPerl 1.7.1 is
>> installed (on a Debian system with the current Debian package in
>> unstable) I get lots of errors of type
>>
>>    Can't locate Bio/Tools/Run/WrapperBase.pm in @INC (you may need to install the Bio::Tools::Run::WrapperBase module)
>>
>> When checking BioPerl 1.6.x hat a file Bio/Tools/Run/WrapperBase.pm
>> which was removed in BioPerl 1.7.x and thus lots of tests are failing.
>>
>> Kind regards
>>
>>      Andreas.
>
>That module (Bio::Tools::Run::WrapperBase) is now part of bioperl-run [1].
>Unfortunately, it seems that there has been no new release of bioperl-run
>since that change.
>
>I am not sure what's the plan for bioperl to make a new release of
>bioperl-run (adding bioperl mailing list to CC) but can Debian patch
>bioperl-run to include those files like upstream has done for the
>next release?
>
>Carnë
>
>[1] https://github.com/bioperl/bioperl-run/commit/acd57a7d14112c5fd2cd979005b072efdaf57679

It may be easier to simply make a new bioperl-run release that includes the module.  I can probably do that this weekend.  

We had a similar issue with Bio-Graphics (which uses another removed module, Bio::Coordinate::Pair).  That has a separate set of problems associated with version numbering that need to be dealt with.

chris
>

_______________________________________________
Bioperl-l mailing list
[hidden email]
http://mailman.open-bio.org/mailman/listinfo/bioperl-l
Loading...